Platform updates and system status enablement

Incident Report for Hidalgo Digital Management

Resolved

Status indicator deployed.
Posted Oct 25, 2025 - 16:33 UTC

Investigating

Establishing platform status system.
Posted Oct 25, 2025 - 14:40 UTC
This incident affected: Client Services (Client Dashboards).